Technical requirements

Here are the browser recommendations for the Spring Day 2010 Portal:


a) If you are using Windows 98, ME, 2000 or XP, Vista we recommend:
1. Internet Explorer 7 or higher
2. Netscape 7.2 or higher
3. Firefox 3.0 or higher
4. Opera 7 or higher


b) If you are a Macintosh OS X user (PowerPC and Intel), we recommend:
1. Firefox version 3.0 or higher
2. Opera 9 or higher

Other browsers on other Operating Systems might not offer full compatibility with the Spring Day 2010 Portal.


Flash player 9 is required to run the audio recording tool found on this site.